Docker Machine error: Hyper-V PowerShell Module is not available

Question:

I’ve checked my Hyper-V settings and PowerShell Module is enabled. I’ve also found this documented issue: https://github.com/docker/machine/issues/4342 but it is not the same issue since I do not have VMware PowerCLI installed. The issue was closed with a push to the repo and is supposedly fixed in 0.14.0-rc1, build e918c74 so I tried it anyways. After replacing my docker-machine.exe, I’m still getting the error and still getting the error even if I reinstall Docker for Windows.

For some more background, this error starting happening after a reinstall because my Docker install had an error: https://github.com/docker/for-win/issues/1691, however, I’m not longer getting that issue after reinstalling.

Answer:

When creating a Hyper-v VM using docker-machine on win10, an error was returned”Error with pre-create check: “Hyper-V PowerShell Module is not available”。

The solution is very simple. The reason is the version of the docker-machine program. Replace it with v0.13.0. The detailed operation is as follows:

  1. Download the 0.13.0 version of the docker-machine command. Click to download: 32-bit system or 64-bit system
  2. After the download is complete, rename and replace the ” docker-machine.exe ” file in the ” C:\Program Files\Docker\Docker\resources\bin” directory. It is best to back up the original file.

Source:

Docker Machine error: Hyper-V PowerShell Module is not available by licensed under CC BY-SA | With most appropriate answer!

Leave a Reply